New installation of the Dial-out Client for Windows fails.

Issue:
After installing the Dial-out Client for Windows it fails to work.

Cause:

A. Dial-out Client cannot locate the Perle across a router.
B. Dial-out COM port is not configured for a valid resource.
C. The 833 server is not configured for Dial-out access.
D. The 833RAS modem initialization is incorrect.
E. The T1 line on the 833AS has not initialized.
F. No Modem resources are available.
G. Phone number is incorrect.
H. BRI/T1/PRI channel is not available.

Solution:

A. Dial-out Client cannot locate the Perle across a router.

The Dial-out Client uses broadcasts to communicate to the Perle. If the Perle is across a router then the Perle must be manually polled.
Select the Client -> Client Properties option on the menu bar.
Select the Server tab.
The Client will then display a list of Perle servers on the network.
Select IP Address's and manually add the Perle to the polling list.

Note: if UPD ports are being filtered then you will require to open them. See link below for UDP ports used.

B. Dial-out COM port is not configured for a valid resource.

By default the resource selected is "modem-pool" that is probably not a resource configured on the Perle.
Select the "Browse" button and verify that the Dial-out Client can see available resources on the Perle(s).
Select a resouce from the list or use the "Use Any Available Resource" option.
As the Dial-out Client only supports analog calls the 833IS or 833AS must have internal modem support.

Note: If you are using Windows XP then you must apply the lasted Software Fixes to be able to locate the Perle and Windows XP will boot with an (M)303 error.
See link below for Software Fixes.

You can now proceed to add a modem to the Dial-out COM port. If you are using the Perle 833AS or 833IS then add the PerleDSP modem using the inf file found on the CDROM.

Note: if any other Dial-out type client (such as the Shiva Client) is currently installed then the two Clients will conflict. In some cases an incomplete uninstall of another Client will cause the Perle Dial-out to fail on loading and the Dialout COM port will not be available.

C. The 833 server is not configured for Dial-out access.

Ensure that the Ports/Channels on the 833 are enbled for Dial-out access.
Note: the 833AS will not be seen by the Dial-out Client if the T1 line is not up.

D. The 833RAS modem initialization is incorrect.

Ensure that the Modem type configured in the Perle server configuration matches the modem physically connected and that the Modem added to Windows matches the modem type also. A mismatch in the Windows modem type may cause errors when initializing (a Windows modem log will indicate this).

If the closest modem type configured in the Perle does not work then try using the basic "Hayes" modem type.

E. If there is no T1 lines attached to the 833AS or if the T1 line has not initialized then the 833AS will not advertise itself to the Dial-out Client.

Configure a T1 line first. Verify with the Event Log that the T1 line is up.

F. Dial-out is only supported for an Analog modem resource. If you are using an 833IS or 833AS you must have the Analaog Modem support for the unit (and the BRI/PRI must support voice calls).

G. Verify that the phone number is correct and that the call does not need an extention ie. "9".
You can enable a modem log in the Modem properties to capture the AT commands sent to the modem. The number called will look like the below example:
09-24-2003 12:29:14.63 - Dialing.
09-24-2003 12:29:14.63 - Send: #,,##########
In this example the number that was configured in the Dialup Networking connection was Area Code = 123 and Phone Number = 1234567.
The number Windows actually called was "9,,1231234567". The Dialing Properties configured in Dialup Networking automatically added the "9,,"

H. The 833IS and 833AS will use the first available channel that is enabled to perform the call. If you do not have a physical line attached to a port then ensure that the channels are disabled. Make sure you do this for all cards.
Note that the Perle will not record an error in the Event Log if it attempts an DO call on a channel that is not connected.

Related Articles:
1.) How to obtain a modem initialization string using Windows
2.) Dial-out Client for Windows cannot see Perle servers over IPX
3.) What TCP/UDP ports are used for communication

Related Links:
1.)  http://www.perle.com/support_services/software_fixes.shtml
System file update required for Dialout for Windows when installed on Windows XP using the TCP/IP protocol.
Software Fixes


Article ID:
30
Published:
1/6/2003 10:19:12 AM
Last Modified:
9/10/2004 2:03:44 PM
Keywords:
dialout, dial out
Issue Type:
Trouble Shooting